Delay on transfers
Incident Report for Lunar Banking Services
Resolved
All payments have now been successfully processed.
We apologize for any inconvenience this may have caused.
Posted Jan 14, 2025 - 09:02 CET
Identified
Our payment processor has informed us that incoming and outgoing transfers for SEK and NOK are currently delayed. They are working to fix the issue, and all transfers should be completed by January 14, 2025, at the latest. We are keeping a close eye on the situation and staying in touch with them for updates.

If you have any questions regarding this maintenance, please reach out to us at the following email address: supportbankingservices@lunar.app
Posted Jan 13, 2025 - 14:32 CET
This incident affected: 🔄 Payment processing: Domestic credit transfers (Domestic credit transfers - SEK, Domestic credit transfers - NOK).